No metadata tags showing up at all

Question:
JTS-post Problem Description wrote:
No metadata showing up at all.
JTS-post Actions Taken To Resolve wrote:
Enabled Metadata from the global configuration, added metadata to all the articles, installed a SEF plugin - still NO metadata tags in the final HTML AT ALL!

JTS-post Diagnostic Information wrote:
Joomla! Version: Joomla! 1.5.22 Stable [ senu takaa ama woi ] 04-November-2010 18:00 GMT
configuration.php: Not Writable (Mode: 444 ) | Architecture/Platform: Linux 2.6.18-194.32.1.el5PAE ( i686) | Web Server: Apache | PHP Version: 5.2.17
PHP Requirements: register_globals: Disabled | magic_quotes_gpc: Enabled | safe_mode: Disabled | MySQL Support: Yes | XML Support: Yes | zlib Support: Yes
mbstring Support (1.5 or above): Yes | iconv Support (1.5 or above): Yes | save.session_path: Not Writable | Max.Execution Time: 30 seconds | File Uploads: Enabled
MySQL Version: 5.0.91-log ( brandedalive.db.7660830.hostedresource.com via TCP/IP )

JTS-post Extended Information wrote:
SEF: Enabled (without ReWrite) | Legacy Mode: Disabled | FTP Layer: Disabled | htaccess: Implemented
PHP/suExec: User and Web Server accounts are the same. (PHP/suExec probably installed)
PHP Environment: API: cgi-fcgi | MySQLi: Yes | Max. Memory: 32M | Max. Upload Size: 2M | Max. Post Size: 8M | Max. Input Time: -1 | Zend Version: 2.2.0
Disabled Functions:
MySQL Client: 5.0.77 ( latin1 )
Answers
mcsmom wrote:
When you say "a" sef plugin? Do you mean you enabled the one that comes with Joomla!?

Under that I mean ARTIO JoomSEF.
So if you turn that off, do things work as expected?
mcsmom wrote:
So if you turn that off, do things work as expected?

Unfortunately, no the problem does not disappear - turning this component on and off was my first action (sorry for not specifying).
Mystery solved. For reasons beyond my understanding, the template index file was missing one line: <jdoc:include type="head" />.

Thanks mcsmom !
That's a Smart Move! Economy Hosting for $1.99/mo.